Sadece Ödeme ve Login sayfasında SSL kullanmak?

admin

Administrator
Yönetici
Katılım
13 Ağu 2009
Mesajlar
3,196
Tepkime puanı
1
Puanları
38
Yaş
37
Konum
Bursa
Web sitesi
www.opencart-tr.com
Zaten her sayfada SSL aktif değil sadece gerekli sayfalarda SSL mevcut.
Hesabım Oturum açma ve ödeme sayfalarında diğer sayfalar normal http adresleri ile açılmakta
 

mdogan35

OpenCart-TR
Katılım
24 Ocak 2011
Mesajlar
110
Tepkime puanı
0
Puanları
16
Yaş
45
Konum
İzmir
Web sitesi
www.cicekkuryesi.com
Arkadaşım SSL sertifikan var ise admin panelindeki SSL kullan kısmından SSL kullanımına geçebilirsin ve eka7a arkadaşımızında dediği gibi SSL gerekli yerlerde kullanılıyor. Ödeme gibi... SSL sertifikanız yoksa SSL kullanamazsınız. Bu hizmeti veren bazı firmalardan yardım isteyebilirsiniz.
 

okansayin

OpenCart-TR
Katılım
24 Mar 2010
Mesajlar
52
Tepkime puanı
0
Puanları
0
Yaş
34
Konum
Ankara
Web sitesi
www.cicekkapinda.com
evet zaten ssl im var ama ssl i aktif edip mağaza url sini http:// olrak bırakınca bazı sayfalarda ssl oluyor doğru ama, bu sayfalardada hep güvenli olmayan dosyalar mevcut gibi ssl hatası veriyor
 

unsound

OpenCart-TR
Katılım
23 Eyl 2010
Mesajlar
209
Tepkime puanı
0
Puanları
0
Yaş
41
Konum
İstanbul
okansayin' Alıntı:
evet zaten ssl im var ama ssl i aktif edip mağaza url sini http:// olrak bırakınca bazı sayfalarda ssl oluyor doğru ama, bu sayfalardada hep güvenli olmayan dosyalar mevcut gibi ssl hatası veriyor

Hocam nasıl düzelttin ssl ini?
Bende Aynı hataları alıyorum,yardımcı olabilirmisin?
 

okansayin

OpenCart-TR
Katılım
24 Mar 2010
Mesajlar
52
Tepkime puanı
0
Puanları
0
Yaş
34
Konum
Ankara
Web sitesi
www.cicekkapinda.com
Öncelikle 1.4.9.x sürümleri başta olmak üzere ssl sıkıntısı çeken arkadaşlara yardımcı olabilirim. Kodlardan kaynaklanan hataları düzelterek ssl sadece ödeme ve giriş sayfasında oluyor. Gerekli işlemlerin nasıl yapılması gerektiğini konuyu derleyip daha sonra yayınlayacağım.
 

cyberwolf

OpenCart-TR
Katılım
22 Ocak 2011
Mesajlar
22
Tepkime puanı
0
Puanları
0
Benimde sitemde tüm sayfalarda ssl çalışıyor halbu ki sadece ödeme ve kullanıcı sayfasında çalışması gerekiyordu.. Yardımcı olabilir misiniz.

Problemi çözdüm gibi şu şekilde yaptım bir hataya sebebiyet verir mi ?

Eski Config.php dosyasında şu şekildeydi

<?php
// HTTP
define('HTTP_SERVER', 'https://www.xxxc.com/');

// HTTPS
define('HTTPS_SERVER', 'https://www.xxxc.com/');

Yeni config dosyası şu şekilde

<?php
// HTTP
define('HTTP_SERVER', 'http://www.xxxc.com/');

// HTTPS
define('HTTPS_SERVER', 'https://www.xxxc.com/');
 
Üst