Register Globals ve Magic Quotes GPC Sorunu

Zone-s

OpenCart-TR
Katılım
14 Nis 2010
Mesajlar
5
Tepkime puanı
0
Puanları
0
Sa arkadaşlar siteyi inceledim ama kurulumu anlatan detaylı bi bilgi bulamadım resim veya video şeklinde bir anlatım olsa inanın opencart tavan yapar ülkemizde.. şimdi ben kurmak istediğim siteye attım dosyaları ama olmadı şu hatayı görüyorum..
Register Globals: On Off
Magic Quotes GPC: On Off
diğerleri tamam.. yani dosyalar yazılabilir sıkıntı yok nedir bu hata??
sitem: zone-s.org:s
 

GoLdWrisT

OpenCart-TR
Katılım
9 Nis 2010
Mesajlar
4
Tepkime puanı
0
Puanları
0
RE: Kuramadım bi türlü..

Register Globals bunu kapatmanın bi yolu var söylediklerimi uygularsan tabi masa üstüne htaccess adlı bit not defteri oluştur aç içine şu kodları yaz

# register_globals ayarını kapat
php_flag register_globals Off

bunları yazdıktan sonra kaydet kapa ftp programını aç hostuna bağlan ve masaüstünde oluşturduğun htaccess dosyasını ftp den ana dizine at attıktan sonra htaccess.txt şeklinde göüzkür siz onu yeniden adlandırın .htaccess aynen böyle yazın sonra ftp programını kapatın . sonra kurulum sayfasını yenileyin Register Globals : yeşil olacak yane sorun ortadan kalkmış olacaktır .
hmm kardeş sana dediğim htaccess dosyanın içine php_flag magic_quotes_gpc off bunuda ekle ftp 'den ana dizine at . Yada altta verdiğim kodu komple kopyala yapıştır yeniden at düzelecektir .

Kod:
# register_globals ayarını kapat
php_flag register_globals Off
php_flag magic_quotes_gpc off

Not : Alttaki 2 hata çözülmüştür .
Register Globals: On Off
Magic Quotes GPC: On Off
 

skarta

OpenCart-TR
Katılım
11 Tem 2010
Mesajlar
3
Tepkime puanı
0
Puanları
0
aynı sorun bende de var. Daha once opencart kuruluydu dosyaları sildim yeniden hosta attım veri tabanı olusturamıyorum çunku

Register Globals: On Off
Magic Quotes GPC: On Off

hataları alıyorum. Önceden kurulu ve çalışıyodu hostta. GoLdWrisT dediğini yaptım ama hala sorun çözulmedi. yardım lutfen...
 

mirac

OpenCart-TR
Katılım
7 Şub 2010
Mesajlar
1,383
Tepkime puanı
0
Puanları
0
Yaş
41
Konum
Beykoz____
Web sitesi
www.notebook-cantasi.com
skarta' Alıntı:
aynı sorun bende de var. Daha once opencart kuruluydu dosyaları sildim yeniden hosta attım veri tabanı olusturamıyorum çunku

Register Globals: On Off
Magic Quotes GPC: On Off

hataları alıyorum. Önceden kurulu ve çalışıyodu hostta. GoLdWrisT dediğini yaptım ama hala sorun çözulmedi. yardım lutfen...

Sunucunuzla görüşmeyi denedinizmi..
 

tahsn85

OpenCart-TR
Katılım
6 Ağu 2010
Mesajlar
15
Tepkime puanı
0
Puanları
0
Register Globals ve Magic Quotes GPC off olarak kurulumu yaptım belirttiğiniz değişiklikleri şimdi yapıp ftpden yüklesem bu sorun çözülmüş olurmu yoksa siteyi silip baştan mı kurmamı tavsiye edersiniz?
 

tahsn85

OpenCart-TR
Katılım
6 Ağu 2010
Mesajlar
15
Tepkime puanı
0
Puanları
0
Çok teşekkürler Allah Razı Olsun.
 

mrtkpt

OpenCart-TR
Katılım
22 Eyl 2010
Mesajlar
7
Tepkime puanı
0
Puanları
0
http://hemenal.in aslı siteme opencart kurdum sunucumlada görüştüm Register_globals ayarları ile ilgili fakat hala düzelmedi
ztn izinli olması gerekn dosyaların chmodları 777 olarak ayarlı php.ini dende safe mode kapalı sunucumla görüşüp Register_globals'i açtırdım fakat düzelemdi. yardım edebilecek arkadaş varmı acaba?
 

admin

Administrator
Yönetici
Katılım
13 Ağu 2009
Mesajlar
3,196
Tepkime puanı
1
Puanları
38
Yaş
37
Konum
Bursa
Web sitesi
www.opencart-tr.com
mrtkpt' Alıntı:
http://hemenal.in aslı siteme opencart kurdum sunucumlada görüştüm Register_globals ayarları ile ilgili fakat hala düzelmedi

ztn izinli olması gerekn dosyaların chmodları 777 olarak ayarlı php.ini dende safe mode kapalı sunucumla görüşüp Register_globals'i açtırdım fakat düzelemdi. yardım edebilecek arkadaş varmı acaba?

Kurulum aşamasında tüm yazma izinler ve diğer aşamalardan onay aldınız mı? Hangi php.ini dosyasından bahsediyorsunuz. OpenCart ile gelen ise o örnek ayarların bulunduğu php.ini dosyasıdır. Çoğu sunucuda php.ini dosyasına müdahale etme izni kullanıcıya vermez. Eğer sizin varsa örnek dosyadaki ayarları kendiniz(sunucu panelinizde bu dosya ile ilgili bir seçenek mevcuttur) yoksa sunucu söyleyerek ayarlarınızı ona göre değiştirmelerini isteyiniz.

Register_globals açık değil kapalı konumda olması gerekir. İlk sayfada nasıl kapatılacağı yazmaktadır ancak bazı sunucularda bu şekilde bir sonuç alamayabilirsiniz. Bu durumda yine sunucunuza başvurmanız gerekir.
 

sinan

OpenCart-TR
Katılım
21 Eki 2010
Mesajlar
63
Tepkime puanı
0
Puanları
0
son bir ayar kurulumda

forumda arama yaptım okudum ancak kafama şu takıldı.
de3cs5.jpg


burası kırmızı onu ayarlayamadım onu pas geçip kuruluma devam etsem sorun olur mu?
 

adobe

OpenCart-TR
Katılım
28 Kas 2010
Mesajlar
241
Tepkime puanı
0
Puanları
0
Merhaba Arkadaşlar bu sorunu şu şekilde çözebilirsiniz
upload klasörünün içindeki .htaccess.txt dosyasını açın sonra boş alt satıra geçin ve şu kodu yazın
# register_globals ayarını kapat
php_flag register_globals Off
php_flag magic_quotes_gpc off bu kodu komple yapıştırın sonra sunucunuza bağlanıp bu txt dosyasını atın ve sa tuş yaparak yeniden adlandır deyin ve .txt kısmını silin normal pc de bunu değiştiremezsiniz haberiniz olsun bir uzantı girin hatası verecektir .txt uzantısını kaldırdıktan sonra kurulumda 2 side yeşil yanacaktır bu kadar olay bitmiştir hayırlı olsun sunucunuzu aramanıza gerek kalmadan basitçe işlemi bitirebilirsiniz.
 

ciyaco

OpenCart-TR
Katılım
4 Ocak 2011
Mesajlar
1
Tepkime puanı
0
Puanları
0
pc deki sunucumuzda nasıl off yapacamızı bilen var mı?
 

göktürk

OpenCart-TR
Katılım
30 Mar 2011
Mesajlar
61
Tepkime puanı
0
Puanları
0
RE: Kuramadım bi türlü..

GoLdWrisT' Alıntı:
Register Globals bunu kapatmanın bi yolu var söylediklerimi uygularsan tabi masa üstüne htaccess adlı bit not defteri oluştur aç içine şu kodları yaz

# register_globals ayarını kapat
php_flag register_globals Off

bunları yazdıktan sonra kaydet kapa ftp programını aç hostuna bağlan ve masaüstünde oluşturduğun htaccess dosyasını ftp den ana dizine at attıktan sonra htaccess.txt şeklinde göüzkür siz onu yeniden adlandırın .htaccess aynen böyle yazın sonra ftp programını kapatın . sonra kurulum sayfasını yenileyin Register Globals : yeşil olacak yane sorun ortadan kalkmış olacaktır .
hmm kardeş sana dediğim htaccess dosyanın içine php_flag magic_quotes_gpc off bunuda ekle ftp 'den ana dizine at . Yada altta verdiğim kodu komple kopyala yapıştır yeniden at düzelecektir .

Kod:
# register_globals ayarını kapat
php_flag register_globals Off
php_flag magic_quotes_gpc off

Not : Alttaki 2 hata çözülmüştür .
Register Globals: On Off
Magic Quotes GPC: On Off




teşekkür ederim dediğinizi yaptım
sayfayı bile yenile demeden kırmızı yeşile döndü
emeğinize sağlık.
 

Oguzz13

OpenCart-TR
Katılım
27 Kas 2011
Mesajlar
25
Tepkime puanı
0
Puanları
0
htaccess dosyasını değiştirmeye gerek yok.

Ana dizindeki php.ini dosyasının ismini php5.ini olarak değiştir. Zaten ayarları "off" yapan değerler içinde yazılı fakat isimden dolayı php5 okumuyor.

Dosya adını php5.ini şeklinde değiştirince sorun çözülüyor.
 

akrepxxx1988

OpenCart-TR
Katılım
9 Şub 2012
Mesajlar
40
Tepkime puanı
0
Puanları
0
arkadaşlar aynı sorun bende var burda denilen ayarları uyguladım.ama hata aynen devam ediyor ne yapmak gerek :(
.htaccess.txt içeriği bu

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200
 

Ekli dosyalar

  • vipr.JPG
    vipr.JPG
    12.3 KB · Görüntüleme: 28
Üst