OpenCart Güncellemek Neden Bu Kadar Zor?

@RTHuR

OpenCart-TR
Katılım
22 Nis 2010
Mesajlar
48
Tepkime puanı
0
Puanları
0
valla ustalar kızmayın gücenmeyin ama kimsenin emegine yaptıgı calısmay asaygısızlık felan algılamayın ama bişi sölemek istiyorum opencart nekadar sorunlu bir scrip sürüm yükseltirken sorun modül atarken sorun bunun daha basit bir yolu yokmu onu düzeltiyom o bozuluyor bunu düzeltiyom öteki bozuluyor anlav veremiyom
 

mirac

OpenCart-TR
Katılım
7 Şub 2010
Mesajlar
1,383
Tepkime puanı
0
Puanları
0
Yaş
41
Konum
Beykoz____
Web sitesi
www.notebook-cantasi.com
RE: opencart 1.4.8

Yaptığınız değişiklikleri ileriye dönük yaparsanız bir sorun olmaz.. Uydurmasyon deneme yanılma olarak yaparsanız hata almanız kaçınılmaz..

Daha iyi sorunsuz bir yazılım istiyorsanız ve bu işi kurumsal yapıcam diyorsanız gidip bi firmadan yıllık binlerce dolar verip paket satın alabilirsiniz..

Not: O kadar para verip aldığınız halde en ufak bir kod ekleyemiyorsunuz bilginize..

Takdir sizin..
 

admin

Administrator
Yönetici
Katılım
13 Ağu 2009
Mesajlar
3,196
Tepkime puanı
1
Puanları
38
Yaş
37
Konum
Bursa
Web sitesi
www.opencart-tr.com
OpenCart sizin dediğiniz gibi sorun bir script değil. Bahsettiğiniz konularda sadece opencartta özgü birşey değildir. Her yazılımda olduğu gibi güncellemelerde yapılan değişikler eski versiyonlara uyum sağlayacak diye bir şey yoktur.

Şuan forumda kullandığımız mybb yazılımı da güncellemesi çıktığında eski modüllerin uyum sağlayacağının bir garantisi yoktur.

Modüllere sorunlu diyorsunuz ama 1.4.1 den 1.4.8 yapılan modüllerin çoğu birbiri ile uyumludur. Uyum sorunu yaşayanların ise bir kaç kod değişikliği ile uyum sağlanmaktadır.

Sürüm güncellemede son 3 versiyonda kolaylaştırılmıştır.
 
Üst