GD ve cURL eklenti sorunu

sndbilisim

OpenCart-TR
Katılım
13 Mar 2010
Mesajlar
6
Tepkime puanı
0
Puanları
0
Yaş
41
Konum
Sakarya
Web sitesi
www.sndbilisim.com
Free bir hostinge kurmak istediğimde sorun yok kurulumu yapıyorum. Ancak kendi hostuma kurulum yapmak istediğimde aşağıdaki eklentileri istiyor. Bu konuda ne yapabilirim. Yardımlarınızı rica ederim..




Eklentiler Geçerli Ayarlar Gerekli Ayarlar Durum
MySQL: On On Good
GD: Off On Bad
cURL: Off On Bad

ZIP: On On Good
 

admin

Administrator
Yönetici
Katılım
13 Ağu 2009
Mesajlar
3,208
Tepkime puanı
1
Puanları
38
Yaş
36
Konum
Bursa
Web sitesi
www.opencart-tr.com
php.ini dosyanızda bu ayarları açmalısınız. Eğer bu dosyaya erişim izniniz yoksa sunucunuza başvurmalısınız.
 

admin

Administrator
Yönetici
Katılım
13 Ağu 2009
Mesajlar
3,208
Tepkime puanı
1
Puanları
38
Yaş
36
Konum
Bursa
Web sitesi
www.opencart-tr.com
cURL için php.ini dosyasında ;extension=php_curl.dll bulun başındaki noktalı virgülü silin

GD içinde aynısını yapın tam emin değilim ama buna benzer birşey olması lazım ;extension=php_gd2.dll

Tabi bunları aynı zamanda sunucunuzda kurulu olması lazım. Bunları deneyin kurulumu tekrar başlatın.
 

sndbilisim

OpenCart-TR
Katılım
13 Mar 2010
Mesajlar
6
Tepkime puanı
0
Puanları
0
Yaş
41
Konum
Sakarya
Web sitesi
www.sndbilisim.com
php.ini dosyasının ilk hali ;

magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 64M;
max_execution_time = 18000;
max_upload_filesize = 100M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;

şeklindeydi.

magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 64M;
max_execution_time = 18000;
max_upload_filesize = 100M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;
extension=php_curl.dll;
extension=php_gd2.dll;

olarak değiştirdim. Ancak sorun yine aynı...
 

admin

Administrator
Yönetici
Katılım
13 Ağu 2009
Mesajlar
3,208
Tepkime puanı
1
Puanları
38
Yaş
36
Konum
Bursa
Web sitesi
www.opencart-tr.com
extension=php_curl.dll;
extension=php_gd2.dll;

Bu ikisinin sonunda notkalı virgül ";" olmayacak

Ayrıca bahsettiğiniz php.ini dosyası opencart ile gelen ise ondaki değişiklikler işe yaramaz o sadece kullanmanız gereken örnek ayarlar.
 

sndbilisim

OpenCart-TR
Katılım
13 Mar 2010
Mesajlar
6
Tepkime puanı
0
Puanları
0
Yaş
41
Konum
Sakarya
Web sitesi
www.sndbilisim.com
Sayın eka7a;
Bilgilendirme ve hızlı cevaplarınız için teşekkürler.


magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 64M;
max_execution_time = 18000;
max_upload_filesize = 100M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;
extension=php_curl.dll
extension=php_gd2.dll

şeklinde düzenledim. Ancak Hala aynı sorunu alıyorum..
Sanırım hostta kurulu değil başka seçenek kalmıyor gibi. Host firmasına yazdım bakalım onlardan ne bilgi gelecek.
 

admin

Administrator
Yönetici
Katılım
13 Ağu 2009
Mesajlar
3,208
Tepkime puanı
1
Puanları
38
Yaş
36
Konum
Bursa
Web sitesi
www.opencart-tr.com
Bahsettiğiniz php.ini dosyası opencart ile gelen ise ondaki değişiklikler işe yaramaz o sadece kullanmanız gereken örnek ayarlar. Sunucunuzdaki asıl php.ini dosyasında değişiklik yapılması gerekiyor.
 

NATURON

OpenCart-TR
Katılım
9 May 2010
Mesajlar
19
Tepkime puanı
0
Puanları
0
peki bu dosyaya nerden ulaşıcaz yan izin varmı yokmu nerden öğrenicezz

phpmyadmin fln mı bi açıklama yapsanız
 

Ömür Akgün

OpenCart-TR
Katılım
23 Nis 2010
Mesajlar
4
Tepkime puanı
0
Puanları
0
paneliniz cpanel ise yeniden apache derleyerek. secenekler sırasında gd ve curl destegini işaretleyin. sorunuzun çözülecektir.
 

lopi03

OpenCart-TR
Katılım
27 Haz 2010
Mesajlar
2
Tepkime puanı
0
Puanları
0
Kurulumda Hata (lütfen yardım)

4602.jpg
kurulumda görüldügü gibi böle bir hata alıyormm devam ettridigimde kurulum gerçekleşiyor lakin bu hatayı düzeltemeden devam ettirmek istemiyorum ileriki aiamalarda bir hata almamak için bu hatayı nasıl düzeltebilirim [/code]
 

deathguards

OpenCart-TR
Katılım
26 Tem 2010
Mesajlar
13
Tepkime puanı
0
Puanları
0
GD Extension Hatası

Arkadaşlar merhaba forumdaki GD Extensions hatasına baktım.Cevabı ;

php.ini dosyanızda bu satırı bulun ;extension=php_gd2.dll ve önündeki ";" işaretini silip kaydedin.
php.ini dosyasına erşiminiz yok ise sunucunuzdan isteyiniz.

Kendime ait bir vps sunucum var. (Linux centos-Whm panelli ) VNCserver aracılığı ile servera bağlantı yaptım. php.ini dosyasının içindek, ";extension=php_gd2.dll" kelimesini buldum sonra önündeki " ; " işaretini kaldırdım. Sonra konsoldan sunucuya restart attım. Fakat GD extension hatası bir türlü çözemedim. GD extensionsu tekrar kuruyorum olmuyor update yapıyorum olmuyor.Ne yapmam gerekli yardımlarınızı bekliyorum
 

admin

Administrator
Yönetici
Katılım
13 Ağu 2009
Mesajlar
3,208
Tepkime puanı
1
Puanları
38
Yaş
36
Konum
Bursa
Web sitesi
www.opencart-tr.com
Bunu deneyiniz
http://forum.opencart-tr.com/thread-539-post-6303.html#pid6303
Ama sunucu bilgisi daha iyi olan arkadaşlar cevap verirlerse daha iyi olur
 

deathguards

OpenCart-TR
Katılım
26 Tem 2010
Mesajlar
13
Tepkime puanı
0
Puanları
0
Nette yazan herşeyi denedim.Olmuyor olmuyor.Apache yi yeniden derleme yapamadım.Daha dogrusu yanlış birşey yaparım diye hiç uğraşmadım.B
 

ulusoy

OpenCart-TR
Katılım
11 Eyl 2011
Mesajlar
1
Tepkime puanı
0
Puanları
0
merhaba "GD" eklentisini kurmak için aşagıdaki çizergeyi uygulayın
sunucuya root yetkisi olan arkadaşlar yapacaktır bu işlemi eğer hosting vps reseller kullanıyorsanız kiraladıgınız yer ile görüşüp apache derlemesi yaptırmak ve GD eklentisini kurdurmak istiyorum demeniz yeterli bilmiyorsa bu linki verin yapsın :)

şimdi root yetkisi olan arkadaşlar için yapması gereken..

WHM - Apache Update menüsü üzerinden apache derlemesi yapmak göründüğü kadar karışık olmadığı gibi yeterince kolaydır. Sadece uygun seçenekleri seçmek problemsiz derlemenin bitmesine sağlayacaktır.

Örnek Sunucu Panel Versiyonu : WHM 11.30.4 (build 6)
CENTOS 6.0 x86_64 standard on server

Kolaylık açısından madde madde seçilmesi gereken kısımları yazacağım.


1 - WHM - Apache Update kısmına giriyoruz.

2 - Burada “PHP Security” i seçip “Start customizing based on profile” e tıklayarak devam ediyoruz.

3 - Daha sonra hangi Apache versiyonunu kurmak istediğimiz soracak. Ben Apache 2.2 kullandığımdan aşamayı o şekilde ilerleteceğim. Apache 2.2 i seçip “Next Step” yapıyoruz.

4 - PHP versiyonumuzu seçiyoruz, PHP 5 i seçip “Next Step” yapıyoruz.

5 - PHP 5'in sürümünü seçiyoruz, seçip “Next Step” yapıyoruz.

6 - Geldik “Short Options List” kısmına , bu kısımda kısaca genel eklentilerimizi seçiyoruz. Benim seçtiklerim,

-Frontpage
-Mod SuPHP
-EAccelerator for PHP
-IonCube Loader for PHP
-Mod Security
-Suhosin for PHP[Tercihen]
-Zend Optimizer for PHP


bunları seçip “Exhausetive Options List” e tıklayarak devam ediyoruz.

7 -
Bu kısımda ek bileşenleri seçiyoruz. Benim genel olarak seçtiklerim.


not : Bu eklentilerin sunucuda olması gereken eklentiler eğer sadece "GD" eklemek isterseniz Ctrl + r basıp GD yazın bulup sadece onu tıklayın gerisini ellemeyin...

Asis
AuthnDefault
Deflate
Env
Expires
Fileprotect
Frontpage
Headers
MemCache
Mod SuPHP
Proxy
UniqueId
EAccelerator for PHP
IonCube Loader for PHP
Mod Security
Suhosin for PHP[isteğe bağlı]
Zend Optimizer for PHP
Bcmath
CGI
Calendar
Curl
CurlSSL
FTP
Force CGI Redirect
GD
Iconv
Imap
Magic Quotes
Mbregex
Mbstring
Mysql
Mysql of the system
POSIX
Path Info Check
Pear
Sockets
TTF (FreeType)
XmlRPC
Zlib

Bunları seçip , Save and Build ‘ basarak derleme işlemini başlatıyoruz. Sunucu özelliğine bağlı olarak ortalama 20-30 DK sürebilir.
 

desmond23

OpenCart-TR
Katılım
9 Ara 2013
Mesajlar
2
Tepkime puanı
0
Puanları
0
not defterindeki değişikliğe ek olarak resimlerde seçili olarak gösterdiğim dosyaların adını resimde verdiğim şekilde değiştiriniz sorun çözülecektir.
vcp8q.png

vcp9c.png
 
Üst